Tuesday, October 27, 2009

Data Migration Manager Troubles with CRM 4.0

Today I spent quite a lot of time trying to figure out why the data migration manager would not let me sign in.

I'd just installed Rollup Pack 7, and noticed that there was no Data Migration Manager Update available in Rollup Pack 7, so I installed Rollup Pack 6's version of this update.

Everytime I tried to login, it would complain that ...

"You must have the System Administrator Security Role to use this Tool".

I was puzzled, I checked multiple times to make sure that the user I put in during the install was correct, I searched the web - but this error had not be reported anywhere by anyone.

Finally I decided to remove the Rollup Pack 6 update (only the update) for the Data Migration Manager, and to my surprise this worked! Infact I was even more surprised to find that it did not complain that there were updates available for it (which it usually does...).

Anyway, I re-installed the Data Migration Manager Rollup 6 Update and it now works.

So the fix is to Re-install if you get this error message.

[UPDATE] Came into work this morning, and a member of my team had exactly the same problem on a completely different server, Wonder if there's a Data Migration Manager Rollup-7 that hasn't been upload to the MS Download Site yet?

[UPDATE2] There's a Rollup Pack 7 installer for the Data Migration Manager Now, however haven't tried it yet to see if it works personally, but apparently it does.


Anonymous said...

Thanks for your advice. I had the same problem.

Anonymous said...

There is a roll-up 7 available for the data migration tool in the mean time. I just installed it, no problem whatsoever.

Matthew Hunter said...

Great, thanks for letting me know.

Matt said...

Have you had any problems with udating records in CRM using DMM?

Matthew Hunter said...

No, as far as I know you can't update records with the Data Migration Manager - it's only really for migrating data from other systems.